Ecommerce Pro / FAQ

Retry of synchronization of shipment

Al generar etiquetas para tus pedidos en la sección de Ecommerce Pro > Orders, it is possible that issues may arise when updating orders in your store. This could prevent orders from being marked as processed or the tracking number from displaying correctly on the order.

When an order requires synchronization, it may appear as Partially fulfilled in the table, and in the shipping information, you will see a message saying Requires shipment synchronization.

Table

Shipping information

Possible Causes

The most common reasons why synchronization may fail include:

  1. Connection problems: Temporary disconnections between your store and our platform.
  2. Request limits: The store may block requests if too many requests are made in a short period of time.
  3. Mistakes in ecommerce configuration: Inconveniences related to your products from our platform.
  4. Errors in the submitted data: Incompatibilities in the data sent to our API.
  5. API server issues: Technical failures in the API that may interrupt synchronization.
  6. Expired tokenIf the authentication token has expired, the synchronization will not be completed.

Solutions

1. Automatic

To improve shipment synchronization, our system automatically retries when certain errors occur (such as 503 or 429 codes). The process works as follows:

  • Automatic retries: In case of an error, the system will try to synchronize the shipment up to 3 times.
  • Waiting time: With each attempt, the waiting time increases by (number of attempts * 1.5 seconds) to avoid overloading the servers.
  • Attempt limit: After 3 unsuccessful attempts, the automatic synchronization of the order will stop.

2. Individual order

When the automatic solution stops, you have the option to synchronize your orders manually and individually.

Fulfillment Pending

Displays orders that require synchronization.

Prepared

Displays orders that have been successfully synchronized.

3. Massive order

You can also perform manual synchronization for several orders at the same time by using the option Synchronizing my shipments. This is especially useful when several orders are not synchronized correctly, allowing you to correct them all at once.


Considerations

  • Synchronization is only possible for packages that have labels.
  • Packages must contain products.
  • Shipments are synchronized individually per order.

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